FAC NOTIFICATION - ZenDesk Outage
Incident Report for FAC EPX
Resolved
This incident has been resolved.
Posted Apr 24, 2022 - 14:25 UTC
Investigating
Good Day,

We are currently experiencing issues with ZenDesk (Our Ticketing Platform). As a result you may receive rejection emails. We are aware of the issue and working to have it resolved as quickly as possible.

Regards,
Your FAC Operations Team
Posted Apr 22, 2022 - 19:48 UTC
This incident affected: FAC E-Commerce EPX Merchants.